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Set up categories, record transactions, and set preferences.
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Find the answers to common problems.
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Saving Data

The Budget Workbook data file is saved each time you enter or change anything.

The data file is saved at the path 

~/Library/Application Support/Snowmint/Budget Workbook/Budget Workbook Data.budgetwb

where the tilde (~) is your home folder.

The Budget Workbook data may be loaded into Budget. All of your categories will be created as Budget envelopes and your 
expense information will be used to initialize the Budget pay allocations. See the Budget Import topic for more information.
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Categories

Categories are used to group similar expenses such as: "Groceries", "Phone", or "Entertainment". The Budget Workbook 
contains an extensive built-in list of categories that you can use.

You can also create your own categories. The easiest way to create a new category is when entering a transaction. In the 
category field, type in any category you want to use. If that category does not exist yet, it will be created.

How To: Edit, add, or delete categories 

1.  Click the Edit button at the top right of the main window. The category editor window will be displayed. 
❍     To add a new category click the New Category button. A category named "New Category" will be created 

and selected in the list. You will probably want to change it's name to something more meaningful. 
❍     To change the name of an existing category, double-click the category name in the list then type the new 

name.
❍     To remove a category, select it in the list then click the Remove Category button.

2.  When finished working with categories, you can close the category editor window.

 

 
 

Note: You can not remove a category that is currently being used by a transaction, as indicated by the check mark in the 
In Use column. 

The initial set of built-in categories will be re-created if you clear your data file. See the Preferences topic for more 
information.
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Transactions

Transaction Entry

The top section of the main window is used to enter your transactions. It has six fields for you to enter basic information 
about any expense you have.

 
 

How To: Enter your expense information 

1.  Set the date of the transaction.
2.  Enter the amount of the transaction. (Required)
3.  Enter who you paid the expense to. (Required)
4.  Enter what the expense was for. (Optional)
5.  Enter the type of expense. (Required)
6.  Check the box if the item is tax deductible. (Optional)
7.  Click the Record button to enter your expense information and create your transaction. (Required)

 

You can set up multiple transaction sets to group related transactions. Once you have created additional transaction sets, a 
small popup menu will appear on the main window allowing you to assign the transaction set which a new transaction wil be 
recorded to.

 

Note: The Expense Paid To and Category fields have popup menus. The workbook places the most recent 10 
transactions in the popup menu. See the Preferences topic for information on how to change the number of recent 
transactions placed in the menu. Both fields use auto-complete so typing a few letters will aid repetitive entries. The 
Categories field contains a list of predefined categories that you can use. You can also enter any category you choose 
directly in the field; it will be added to the list making repetitive entries simple.

 

Displaying Transactions

The bottom section of the main window displays your transactions.
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You can sort any field by clicking in it's column header.

Use the popup menu to select predefined date ranges or enter any date in the From and To fields to display transactions 
within that date range.

You can search for any transaction by entering a few letters that are in the transactions Paid To field into the search box at 
the top right.

Use the Print Transaction button to send a copy of the currently displayed transactions to your printer.

Note: There is a checkbox on the left side of the table. This checkbox can be used to mark transactions for your own 
reasons. For example, if the money is going to be reimbursed by your employer, or a friend is going to pay you back.

At the bottom total information about your transactions is displayed.

See also the Summary topic for displaying transactions from the Summary Amounts tab.

 
Editing Transactions

You can change any field in a transaction. To do so, just double click the field you want to change in the transaction table 
and enter the change.

You can remove any transaction. To do so, just select the transaction in the table by clicking it once and then click the 
Remove button. You will receive a warning asking if you really want to delete the transaction.
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Transaction Sets

Every transaction is part of one and only one transaction set. Initially, there is an implicit transaction set that all transactions 
belong to. Transaction sets allows you to have a completely different group of transactions for different needs. For example, 
you could have one set for home expenses and another for work expenses.

To create additional transaction sets use Window > Transaction Sets....

 

Click the Add Transaction Set button to create a new transaction set. You can change the name of any transaction set by 
double clicking the name and entering a new one. Select a transaction set and click the Remove Transaction Set button to 
delete a transaction set. You can not delete the currently selected transaction set.

Warning: Deleting a transaction set will delete all the transactions associated with that 
set. 

Once you have created additional transaction sets, a small popup menu will appear on the main window allowing you to 
choose which transaction set you're working with.

 
 
 

Note: Currently the only way to move a transaction from one set to another is to first delete the transaction, and then 
reenter it in the other transaction set. 
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Reports

The bottom section of the main window is used to display report information. To view report information click the Reports 
tab. There are three types of report; click the tab to view each report.

For each report you can set the date range of the transactions used in the report. Select a predefined date range from the 
popup menu or enter any date in the From and To fields. The total number of transactions and the number used are 
displayed. To print any report, click the Print Report button.

 
Averages Report

 

 

The "Averages" report shows how often you are spending money in each category and the average amount spent weekly, bi-
weekly, and monthly.

This is the information that will be used if you decide to import your workbook data into Budget. See the Budget Import 
topic for more information.

 
Plan Vs. Actual Report

 

 

The "Plan Vs. Actual" report shows how well you are doing in keeping within your spending guidelines. For each category 
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you can set how much you plan to spend for any period. Use the popup menu to set the Expense Frequency and then enter 
an amount in the Planned column for how much you want to spend for that period. The Averages column shows you the 
average spent during that period, and the Difference column shows how much your spending was over (negative) or under 
(positve) your planned goal.

 
Percentages Report

 

 

The "Percentages" report shows the total amount spent in that category and the percentage of the total amount spent across 
all categories.
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Transaction Summary Information

The bottom section of the main window is used to display information about your transactions. To view summary 
information click the Summary Amounts tab.

 

Use the popup menu to select the format to be used.

Use the buttons on the top right to navigate forward and backward to display the amounts spent in that time period.

Double clicking any amount will display in a separate window the transactions that contribute to that amount.
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Preferences

To set your preferences use Budget Workbook > Preferences....

General tab

Transaction Entry

You can change the number of recent Expense Paid To items kept in the popup menu on the main window; the default is 10.

Check the Clear fields after Record box if you want the transaction entry fields cleared when you click the Record button 
on the main window. If this box is not checked the information will remain so you can easily add more items with similar 
information.

Summary Amounts Tab

The Summary Amounts tab daily view defaults to starting on Sunday, but you can set any starting day you want from the 
popup menu.

You can also set which column of the Summary Amounts tab other views includes today's date. This option does not apply 
to the Daily setting of the Summary Amounts report.

Update tab

Budget Workbook can use your internet connection to check for updates to itself. You can specify whether you want Budget 
Workbook to automatically check for updates and with what frequency to do the check.
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If the Include System Information box is checked, Budget Workbook will send additional non-personal information about 
your system to us at Snowmint Creative Solutions LLC. This information will be used to help us decide what systems to 
support. You can click the Learn More... button to see the exact set of information that Budget Workbook will send. If 
activated, this information will be collected and sent during any check for updates (manual or automatic).

Advanced tab

If you would like to start over with Budget Workbook, click the Clear data file button. This will erase all of your 
transactions and reset the category list to the defaults.
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Registration

You can use Budget Workbook for up to 40 launches on 20 different days before you must purchase a registration code. 
Budget Workbook will occasionally remind you of this fact upon application start up.

You can register Budget Workbook by using Budget Workbook > Enter Registration Code... or Help > Enter 
Registration Code....

 

If you have not yet purchased Budget Workbook, you can click either the Buy Now! button or the Visit Web Store... button. 
You must have an internet connection for either of these buttons to work. The Buy Now! button leads you through the 
purchase without leaving the Budget Workbook application; your registration name and code will automatically be recorded 
and you will receive an email confirmation. The Visit Web Store... button allows you to browse the Snowmint Creative 
Solutions online store and purchase Budget Workbook from there; you will need to enter your name and code from the 
confirmation email into Budget Workbook as described below.

In the fields provided, enter the name and code you received when you purchased the Budget Workbook application. They 
must be entered exactly as shown on your registration; both the name and code are case sensitive. We suggest that you do a 
copy and paste from your sale confirmation email. Once the information has been entered, click the Enter button.
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Loading Workbook Data into "Budget"

The Budget Workbook data may be loaded into a new Budget document. Budget is personal finance application from 
Snowmint Creative Solutions that uses the envelope system. To find out more, visit the Snowmint web site.

How To: Load your workbook data into a new Budget document 

1.  Start the Budget application.
2.  Budget's setup assistant should be displayed. If not, use File > New....
3.  Click the right arrow button to move to the Setup Assistant's import step.
4.  Click the Import Budget Workbook Data File button.
5.  Follow through the rest of the setup assistant steps. Information on how each step relates to your workbook data 

can be found below.

Import Budget Workbook step: When the workbook file has been read, you will see summary information including the 
number of categories and transactions found.

Create Bank Accounts step: Enter your bank account information at this step; this information is not part of Budget 
Workbook.

Create Envelopes step: All of your imported categories have been turned into Budget envelopes. You can add more or 
remove any of the imported envelopes.

Create Pay Sources step: Enter your income information at this step; this information is not part of Budget Workbook.

Note: You must define at least one income source to be able to see your imported expenses in the setup assistant. If you 
don't define a pay source, your data is still imported and you can see it using Budget's Envelope Info window or Budget's 
Pay Allocation table. See the relevant Budget documentation for more information about these features.

Create Budget step: The information shown in the Workbook Plan Vs. Actual report is used to initialize this step. All of 
your envelopes (categories) are displayed down the left side of the table. The amount next to each envelope is the monthly 
amount shown in the Monthly column in the workbook report and all of the Due Every selectors are set to "Monthly". You 
can use the Due Every selector to switch between other frequencies; Budget will use the corresponding amount from the 
workbook data. You can also change any amount manually; this allows you to set a different value instead of using the 
calculated value from the workbook data.

Remaining steps: The other steps in the setup assistant are not affected by the import of Budget Workbook data.

Note: The transactions you created in the workbook are only used to configure the budgeted amount in each of your 
envelopes (categories) and to set up your Budget pay allocations. The transactions themselves are not loaded into the 
envelope history windows.
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Solving Problems

Click a topic below.

I can't save my file. 

Where is my data saved? 

How do I register the Budget Workbook? 

Can my workbook data be used in Budget? 
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Index

Budget - Importing your workbook data into Snowmint Creative Solutions' Budget product. 

Categories - Add, remove, and edit your categories. 

Preferences - Set up the workbook the way you want. 

Register - Register your copy and unlock all it's features. 

Reports - See how you are doing with your expenses. 

Saved data - How and where your data is stored on your computer. 

Summary - See where and when you are spending. 

Transactions - Add, remove, and edit your expense transactions. 

Transaction Sets - Create additional transaction sets to group transactions. 
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